FedSig Touchmaster Delta Mic Issues

Laythrom

New Member
Hello everyone. I’ve come across an issue that I cannot seem to dig up info on and I’m hoping that someone on here might have an idea/answer.

I have a FedSig Touchmaster Delta and for the most part, it works great. Siren functions are perfect and so are the switches. The issue that I’m having (since I got it) is the PA. If you hook up the mic and hit the PTT, the unit makes a sort of hissing sound. (If need be, I can upload a video of it to YouTube or something.) It only does it when it is on PA and you’re messing with the mic. The rest of the time it’s fine.

I’m not sure if it’s the volume pot, the 1/4” jack or if something else is going on. I’d like to keep the unit in service and while it’s absolutely not 100% necessary, having a PA would be nice on the occasions that I need it.

If anyone has any suggestions...I’m all ears.
 

MtnMan

Senior Member
The issue that I’m having (since I got it) is the PA. If you hook up the mic and hit the PTT, the unit makes a sort of hissing sound. (If need be, I can upload a video of it to YouTube or something.) It only does it when it is on PA and you’re messing with the mic. The rest of the time it’s fine.
A little hissing or a lot of hissing? Is the PA functional and intelligible?
 

Online statistics

Members online
12
Guests online
193
Total visitors
205

Forum statistics

Threads
47,682
Messages
419,223
Unanswered questions
8
Members
17,200
Latest member
YesanotherLEOhere
Top Bottom