HHS4200 wecan help

ffjwhite

Registered Member
ok, this one has me stumped big time. I just bought the hhs4200 with the wecan build in. Now I have imported the file from my wecan freedom and I can not get any kind of function out of it. I can not get one module or function on the light bar. Will the hhs4200 be able to run a freedom with a dom of 2010? Also the CP is dated 12/2019. So it is using the current CP. All help would be appreciated. Spent 4 hours trying to figure it out but ended up using the relay outputs and the CP until I can figure this out.
 

FusionWolf

Member
Just because I know this gave me trouble with my liberty board when Command came out: have you tried building the bar in the command software instead of importing it in? I had a similar issue and found that the file type for light bars was different in command software than the sapphire software. Once I built the bar in command It resolved all my issues
 
OP
OP
ffjwhite

ffjwhite

Registered Member
Yeah, the issue with that is, they don't match with my freedom. It only gives me the Freedom IV. I have not actually tried it but with that it has different set up for the light which is completely different than my standard freedom.
 
OP
OP
ffjwhite

ffjwhite

Registered Member
Have you had any luck with this? I have been messing around with it and also have been emailing whelen about the issue as well. For somereason the tech I was talking to, stated that all the wecan bars from 2010 to current should work with the Command software. I also tried running new wires and checking coninuity, per the request of whelen and I still get the same results. I can get the bar to work using the Wecan 7 Software but not the command software. Which to me, leads me to believe its a firmware issue or compatibility issue. I really would like to get the intergrated wecan port to work on this as that is the main reason why I bought this one as well. I was also thinking of just buying the Freedom 2 IO board on eBay but I dont want to spend that kind of money if I am gonna be in the same boat. I am just waiting to hear back from whelen to see what else they have to offer before I continue.
 

FusionWolf

Member
Have you had any luck with this? I have been messing around with it and also have been emailing whelen about the issue as well. For somereason the tech I was talking to, stated that all the wecan bars from 2010 to current should work with the Command software. I also tried running new wires and checking coninuity, per the request of whelen and I still get the same results. I can get the bar to work using the Wecan 7 Software but not the command software. Which to me, leads me to believe its a firmware issue or compatibility issue. I really would like to get the intergrated wecan port to work on this as that is the main reason why I bought this one as well. I was also thinking of just buying the Freedom 2 IO board on eBay but I dont want to spend that kind of money if I am gonna be in the same boat. I am just waiting to hear back from whelen to see what else they have to offer before I continue.
Lemme try and dig into this a bit more today. I woulda sworn I had an original wecan freedom on my drop down.
 

FusionWolf

Member
Hey there sorry it took me so long to get this but I just pulled up a hhs4200 on my Whelen command and I have the option for Freedom 2 in the following options:
44 w split TA
48/54 w split ta
60 w split ta.
Pull up your whelen command, select the hhs4200, select design lightbar, and itll be in the drop down menu directly below the center series and above the freedom 4 lightbar. From there you can design the bar to how yours is set up.15912149814045555284897872880700.jpg
15912150708401793182293344240139.jpg
 
OP
OP
ffjwhite

ffjwhite

Registered Member
Yeah. I have tried that as well. Only issue is, that my is the regular freedom, not the 2.0. Whelen recommends me sending in the unit as they think there is an issue with the wecan port
 

FusionWolf

Member
Yeah. I have tried that as well. Only issue is, that my is the regular freedom, not the 2.0. Whelen recommends me sending in the unit as they think there is an issue with the wecan port
I don't even have an option for an original Freedom with the wecan port programming. I was under the impression that the freedom 2 was the start of the wecan bars
 
OP
OP
ffjwhite

ffjwhite

Registered Member
No, I believed they have a different style IO board to get the split heads option. So I will just send it back to whelen and see what they say
 

FusionWolf

Member
No, I believed they have a different style IO board to get the split heads option. So I will just send it back to whelen and see what they say
It's possible. I cant find a wecan compatible 1st gen freedom option on the whelen site. The freedom 2 is a split head option. For the sake of my own curiosity have you tried programming it under a freedom 2 in the hhs4200?
 
OP
OP
ffjwhite

ffjwhite

Registered Member
I have yeah. It still doesn't work. In fact the whelen command software won't program the CP either. I had to use the Wecan7 software in order to get it to work. But whelen says it should be compatible with all wecans. I am gonna try a liberty on it and see if I can get it to work as well.
 

FusionWolf

Member
I have yeah. It still doesn't work. In fact the whelen command software won't program the CP either. I had to use the Wecan7 software in order to get it to work. But whelen says it should be compatible with all wecans. I am gonna try a liberty on it and see if I can get it to work as well.
That's definitely an interesting one. On my wecan 7 I only have the option for freedom 2 and 4.
 
OP
OP
ffjwhite

ffjwhite

Registered Member
Yeah, in order to make it work, I had to build the bar in wecad5 and then export the freedom WC file. Save it and then import the lightbar design into wecan7. Then it works flawlessly. However if I do that for the command software it won't work.
 

FusionWolf

Member
Yeah, in order to make it work, I had to build the bar in wecad5 and then export the freedom WC file. Save it and then import the lightbar design into wecan7. Then it works flawlessly. However if I do that for the command software it won't work.
That..... is the the most convoluted thing I've ever heard. Something is definitely not right there.
Also for the sake of curiosity have you tried that same process with the hhs4200 software. Not the command but the legacy software.
 
OP
OP
ffjwhite

ffjwhite

Registered Member
The hhs software is the command software, is it not?I have programmed it both pre legacy and legacy version.
 

FusionWolf

Member
The hhs software is the command software, is it not?I have programmed it both pre legacy and legacy version.
Yes and no. The command can do hhs but whelen has in their software downloads the software specifically for the hhs series before command encompassed it all. I'm not sure if itll do anything but maybe work a try. I know that stuff designed in wecad is not the proper file type for command for it to function properly. I encountered this with my liberty and sapphire when command came out.
Another option perhaps have you tried plugging in the freedom to the hhs and importing the bar in command?
 
OP
OP
ffjwhite

ffjwhite

Registered Member
What do you mean, import directly from the bar? I thought this was only done via the CP?
 
OP
OP
ffjwhite

ffjwhite

Registered Member
Lol no worries. I am gonna try the stand alone hhs software. I didn't realize that was an option. Will try that and update the outcome.
 
OP
OP
ffjwhite

ffjwhite

Registered Member
Well after trying the standalone hhs file, I still can not get it to work. Even tried a few new programming files for the wecad to wecan and still nothing. So it looks like I am gonna have to send the unit into whelen.
 

FusionWolf

Member
Well after trying the standalone hhs file, I still can not get it to work. Even tried a few new programming files for the wecad to wecan and still nothing. So it looks like I am gonna have to send the unit into whelen.
Damn was worth a shot. I'm sadly out of ideas at this point, other than a IO board swap. You'll have to let us know what whelen finds
 

Online statistics

Members online
13
Guests online
165
Total visitors
178

Forum statistics

Threads
48,304
Messages
422,265
Unanswered questions
8
Members
17,380
Latest member
ctilley
Top Bottom