• Chat is Back! It's helped many people get the information they've needed in the past... maybe we can get it busy enough to help a new generation of information seekers!

Wanted Strobe Power Supply

JazzDad

Just Another Faceless Member
Silver Supporter
#1
My department is needing a Whelen UPS-188C. This is an 8 channel, 180W unit, Model # 01-0667221-00. It is out of production, but Whelen states they can still service the unit. Repair cost unknown.

I could install two supplies I salvaged from a 10 bucket JetStrobe, but the chief would prefer a direct replacement.

Thank you.
 
#2
Jazzy, by no means am I an expert but I would think using lightbar power supplies to not be best practice as the cable runs are much further than the supply was designed to handle. Maybe use some UPS64’s or the like as they are a sturdier unit designed for varying cable lengths. Just some food for thought.
 

Nolines

Established Member
#4
My department is needing a Whelen UPS-188C. This is an 8 channel, 180W unit, Model # 01-0667221-00. It is out of production, but Whelen states they can still service the unit. Repair cost unknown.

I could install two supplies I salvaged from a 10 bucket JetStrobe, but the chief would prefer a direct replacement.

Thank you.
Any Idea whats wrong with the Unit? also is it the Serial unit or the Regular unit?
I started using Alfa Electronics down here in West Park Fl for repairs, 40 an hour plus parts plus 20 to Diagnose... at least thats what I Paid last time... I havent opened up either of my 188's to see what is going on inside but as long as they arent Encapsulated in crap then he can work on them... Got my 690 back operational after a Diode or Resistor Cracked in half and disabled it.
 
OP
OP
JazzDad

JazzDad

Just Another Faceless Member
Silver Supporter
#5
Serial or Cereal? I know not.

Thanks for the thoughts.
 

Nolines

Established Member
#7
serial you know like the old blink setups thats what those worked with as long as you had the connection point on the supply.... yours the one you listed is the one without...
so is it not firing? is it only working on specific ports?? whats up with it?
 
OP
OP
JazzDad

JazzDad

Just Another Faceless Member
Silver Supporter
#9
... so is it not firing? is it only working on specific ports?? whats up with it?
No output on any channels. Good input voltage. It's still in the truck, so I have not broken it open to see if there are any obviously fried parts.
 

FL05

Registered Member
#12
I got one from my storage unit today. It used however. The odds of finding a new one is pretty slim, and even then it's still a 10+ year old unit.
 

Nolines

Established Member
#13
No output on any channels. Good input voltage. It's still in the truck, so I have not broken it open to see if there are any obviously fried parts.
So No Blown Fuse or Fuses? hmmm... and No Sound of the Capacitors Firing off? if you want to check it if something internally went and its repairable ill send you the address for Alfa or send it to me ill drive it down to them and have the guy replace whatevers replaceable... but ill have him diagnose it first for sure..
 
OP
OP
JazzDad

JazzDad

Just Another Faceless Member
Silver Supporter
#14
Correct, Nolines: no high-pitched sounds. Accessible fuses are good.

Bear with me a few days, FL05.

Well we are talking about decade+ old technology here...
He's an old chief. ;)
 

Nolines

Established Member
#15
Correct, Nolines: no high-pitched sounds. Accessible fuses are good.

Bear with me a few days, FL05.

Yep sounds like something internally blew.. had the same problem with my dashmaster, the guy at alfa fixed it, going to have to open up my 188 as well to see whats up inside, 2 of our 188's arent working well on our rescue and we have a light down.. may need to replace it
 
OP
OP
JazzDad

JazzDad

Just Another Faceless Member
Silver Supporter
#16
Chief sent it to Whelen. Waiting to hear back. ($$$$$$$)
 

Nolines

Established Member
#17
Well When they come back with 245 Dollars or what ever the Current cost is let me know when he decides to not pay that plus the cost of parts and what have you!
 
OP
OP
JazzDad

JazzDad

Just Another Faceless Member
Silver Supporter
#19
Hey, not my decision. That's why he's paid the big bucks. (All volunteer dept.)
 

BLUELIGHT

Registered Member
#21
Hey, not my decision. That's why he's paid the big bucks. (All volunteer dept.)
Yes, I know that syndrome. I'm of the fix it right school of thought too, but if I could pick up a used ( insert item here) for less than $100 and have it delivered in less than a week and have my emergency (insert vehicle) ready for service, I wouldn't hesitate a moment. Then when the repaired one comes back, I'd put it on the shelf for a spare. Not telling how long it'll take for the repairs, if it can be fixed. If no, then there's the expense of re-lighting the truck with LED lights. As a side note, I've had good luck with Whelen strobes. My Dash Master duo still works like brand new, and it must be close to 40 years old. And I have a used Whelen strobe power pack in my POV, and it's probably 20+ years old. Admittedly they weren't used multible times daily, but they still work.
 

Nolines

Established Member
#22
thats like me ive had my strobes longer then my leds and im allready replacing my leds when they die off but still on my same strobes of 20 plus years, dash masters, dash kings, dash misers, grl strobes.. what sucks is when the lenses burn down to looking like a white light instead of its color... that gives me problems with the cops with... hey whats with the blue lights... turn em off and ohh crap they are actually green,,, sorry bout that...
 
OP
OP
JazzDad

JazzDad

Just Another Faceless Member
Silver Supporter
#23
I salvaged the two packs from my old JetStrobe (which has been tossed). He could use the 4 channel, but only needs 4 of the 6 channel pack. Will the 6 channel unit be damaged by not using all the outputs?
 

Nolines

Established Member
#24
dont know, at least on the 188 it works in 4 x 2 x 2 mode... i have them in both my units, one working all 8 the other working 4 never sure about other manufacturers setups, never been as reliable to me as the old Austin, Nova and Whelen line ( at one time all one company now just the Whelen Line Remains ), did he get a quote back on how much to fix it yet?
 

Chat users

Latest Listings

Top Bottom