Touchmaster Delta and Whelen Alpha 12Q Wiring Questions

dasuriano

Member
Have the two sirens installed in my truck and neither are fully functional. I think they're simple fixes, but I just can't figure it out.

I can't get the sweep mode working on the TD. I have a separate switch wired for the horn ring and it isn't tripping the sweep function. I've tried to match the diagram the best I can, but it isn't working correctly. Does it need power or ground or something to function correctly? Or does it just jump between the two connection points on the back of the unit?

And I can get the 12Q to work on manual mode, but not with the wind down. I am fairly certain that the pins aren't the correct ones and they aren't long enough. As I was wire testing the connections, I made contact with the pin end and shifted it, turning on the siren. Does anyone know where I can find replacement pins for the connector?

And last question. I want to wire in the siren brake for the 12Q, but didn't see it in the manual. Which connection is that?
 
OP
OP
D

dasuriano

Member
I did manage to figure out the Alpha 12Q. I had to order new longer pins, but it works correctly now.

I still cannot get the TD to work correctly.
-The sweep does not work. I have tried wiring in a separate switch for Horn Ring, as well as triggering it off a function switch on the siren itself. Neither seem to work.
-The Manual button does not work either. It gets stuck in the depressed position and does not trigger any noise.
-And the Aux switch does not work in either momentary or latched mode.

Is there any hope for the unit?
 

Online statistics

Members online
2
Guests online
25
Total visitors
27

Members online

Forum statistics

Threads
46,589
Messages
416,400
Members
16,362
Latest member
Sztraki2
Top Bottom