Liberty

JohnMarcson

Administrator
May 7, 2010
10,991
Northwest Ohio
So I got my galls liberty today. The bar is great, there is just one thing I can't figure out... If I turn the takedowns or alleys on and THEN apply power to the wire for flashing take downs/alleys they work fine... but if I apply power to the flashing takedown/alley wire first by it's self they don't work/flash....
 

TCO

Member
May 21, 2010
808
Malvern,Pa
sounds like you got a defective bar on your hands,i will gladly dispose of that for you. :D
 

RL1

Member
May 20, 2010
1,650
Ga
Maybe the flashing wire is just the power for the flasher unit and the lights themselves have to have power first to flash? IDK, I'm not a wiring guy.


EDIT: now that I think about it, I'm going to be wrong. My old patriot had flashing takedowns and alleys but they would go to steady burn when I turned on my takedowns (I really need to figure out how to turn that feature on on my new bar).
 

Forum Statistics

Threads
54,242
Messages
450,860
Members
19,225
Latest member
Instinq

About Us

  • Since 1997, eLightbars has been the premier venue for all things emergency warning equipment. Discussions, classified listings, pictures, videos, chat, & more! Our staff members strive to keep the forums organized and clutter-free. All of our offerings are free-of-charge with all costs offset by banner advertising. Premium offerings are available to improve your experience.

User Menu

Secure Browsing & Transactions

eLightbars.org uses SSL to secure all traffic between our server and your browsing device. All browsing and transactions within are secured by an SSL Certificate with high-strength encryption.