Typhoon controller problem

timlinson

Member
My typhoon has went haywire and I've had it for less than a week. The siren knob won't change the siren, and siren tones don't even play anymore including manual and the horn. Not controlling any lights either. I've quadruple checked all wiring and it was working previously...

Here's a video
 

EMT-BLS

Member
Assuming the data cable is okay (make sure it's not crimped or smashed), the controller is toast. RMA it.
 
OP
OP
timlinson

timlinson

Member
Assuming the data cable is okay (make sure it's not crimped or smashed), the controller is toast. RMA it.
I figured it out. We don't need the speaker mic and since it doesn't have a plug in mic, we cut it off. That's what did it. Took the 15 ft mic from the Storm Pro and connected it, works like a charm. Will just mount it out of the way.
 

EMT-BLS

Member
I figured it out. We don't need the speaker mic and since it doesn't have a plug in mic, we cut it off. That's what did it. Took the 15 ft mic from the Storm Pro and connected it, works like a charm. Will just mount it out of the way.
Oh, I did hear that once before. Good to know. Thanks for updating.
 
OP
OP
timlinson

timlinson

Member
Interestingly it also disabled all of the inputs as well, which I found interesting.
 

Online statistics

Members online
3
Guests online
149
Total visitors
152

Members online

Forum statistics

Threads
46,456
Messages
413,564
Unanswered questions
8
Members
16,824
Latest member
trd2000808
Top Bottom