Whelen Liberty Duo WC and Whelen Liberty WC- Assistance Please!

Scoot163

Member
Nov 15, 2013
854
473
Tacoma, WA
I am a mechanical rotator, halogen light guy. I was given the above Liberty bars to work on, one to keep, the other for the guy who gave them to me.

Tony gave me some help in another thread, ( starting a new one 'cause I felt I was hijacking the other), so I bought a WeCan controller module, hooked it up per the instructions and......nothing. Not even a blink.

I checked the fuses, checked to see power going into both bars. I downloaded the WeCan programming software, plugged in the controller and it was recognized immediately. The module says "factory default" on it but I saw no patterns showing in the software program.

I know there is a possibility the I/O boards could be bad. Anything else I can try? Another member mentioned flashing the I/O board with a blank pattern, then creating a new lightbar and pattern and loading that. Looking at it, it wasn't real apparent on how to use the programming software. Any help appreciated.

Do the shield wires need to be connected for the bar to work? I did connect them but nothing happened.

Thanks,

Rich
 
Rich, it sounds like the WeCan modules need to be programmed. You do likely need to 'create' the lightbar file, open it in WeCan and then program it in WeCan.

No need to connect the shield wire for this.
 
Rich, it sounds like the WeCan modules need to be programmed. You do likely need to 'create' the lightbar file, open it in WeCan and then program it in WeCan.

No need to connect the shield wire for this.
Thanks Tony! But how do I create the file? Do I just name a folder in my documents? Heading to bed now but I'll be back on in the morning.
 
There are a couple of ways to create the lightbar file. The easiest in my opinion is to download Whelen's Command software. When you open it select "design lightbar" and select your option/lighthead colors.

If you feel that it is over your ability, feel free to PM me a few photos of your bar and tell me how it is setup and I can create the files and email them to you.
 
There are a couple of ways to create the lightbar file. The easiest in my opinion is to download Whelen's Command software. When you open it select "design lightbar" and select your option/lighthead colors.

If you feel that it is over your ability, feel free to PM me a few photos of your bar and tell me how it is setup and I can create the files and email them to you.
Thanks, I downloaded the WeCan software last night, although it said it was out of date. Should I download the latest version of Whelen Command instead?

I should be able to do this, but will PM you if I have further problems.
 
The WeCan software is just for programing the module to operate the bar. It still will need a lightbar file.

And yes, as NoLimitSquads pointed out, the older control points may need to use the older software. If you bought brand new ones, you should be good to go with Command.
 
The WeCan software is just for programing the module to operate the bar. It still will need a lightbar file.

And yes, as NoLimitSquads pointed out, the older control points may need to use the older software. If you bought brand new ones, you should be good to go with Command.
All the info here is solid, but one thing to add. What is the date on your WC control point? That may dictate which programming software that you need to use.
Okay, the WeCan module I purchased has a date of 1/19 on it.
 
Last edited by a moderator:
Programmed the WC module and the bar lit up.... except for the lights on the driver's side front and rear. Flash patterns only worked on the left. Driver's side alley wouldn't even light up. The traffic advisor function works on both sides. Is this a glitch anyone is familiar with? Programming issue? Thinking maybe the board is bad. It's why I drink. As always any suggestions appreciated.
 
Programmed the WC module and the bar lit up.... except for the lights on the driver's side front and rear. Flash patterns only worked on the left. Driver's side alley wouldn't even light up. The traffic advisor function works on both sides. Is this a glitch anyone is familiar with? Programming issue? Thinking maybe the board is bad. It's why I drink. As always any suggestions appreciated.
That is a good start! My suspicion is that it may be a programming issue. The components are pretty hardy and the programming can be finicky.
 
That is a good start! My suspicion is that it may be a programming issue. The components are pretty hardy and the programming can be finicky.
Maybe so! All of a sudden the driver front patterns began working and wait for it, now the driver's side rear stopped working. Should I try reprogramming it with the new Command software, or stick with the older WeCan program? The bar was made in 2011. The control module in 2018.
 
Maybe so! All of a sudden the driver front patterns began working and wait for it, now the driver's side rear stopped working. Should I try reprogramming it with the new Command software, or stick with the older WeCan program? The bar was made in 2011. The control module in 2018.
I'm going to PM you my email address to have you send me the files and I will take a look to see if I can see anything glaring.
 
  • Like
Reactions: fp13-2

Forum Statistics

Threads
54,420
Messages
451,730
Members
19,325
Latest member
Manutea