Whelen BLINK / B-LINK / Serial thread

fireman846

Member
those aux outs need to be used with relays to activate other options that you might want to add. to run right from that and you will mess something up for sure!! you need to use a relay to turn on for instance a deck light or a gun lock the possabiltys are endless. mr lunch box might be able to help as he is the one i go to.
 

Shawn L

Premium Member
I got that you will only use the output wire to activate a relay, but does the amp provide less than 1.0 amp of positive 12 volts or is it a ground signal.
 

Mrlunchbox

Premium Member
I'm not 100% sure how many amps activate the relay or whatnot. I do know the I have the MPC03 head and one aux. relay is controlling my non b-link/non whelen headlight flasher. The other aux relay is going to control my non b-link LEDS on my push bumper for intersection warning. They aren't installed yet. I actually was unaware I could use those aux inputs until I sent my truck in for the install. I originally didn't have a HLF and the installed told me he could put one in with a relay. Pretty cool stuff.
 

factorone33

Member
We have a vehicle in the shop with an SC setup that we've been toying around with the last week or so,. One of the guys and I have started "hacking" the firmware and software of both the SC and WeCan setups, and we've come up with some fun things for a new demo Charger we're putting together for the shop personnel. I'll post some results once we get something concrete.
 

Mrlunchbox

Premium Member
factorone33 said:
We have a vehicle in the shop with an SC setup that we've been toying around with the last week or so,. One of the guys and I have started "hacking" the firmware and software of both the SC and WeCan setups, and we've come up with some fun things for a new demo Charger we're putting together for the shop personnel. I'll post some results once we get something concrete.
Oh yes, please do! Sounds interesting! :)
 
OP
OP
PJH

PJH

Member
USO131 said:
I need the programing box transporter for the system I have ans software?
The transporter box can be picked up new from Whelen. They are hard to find in the wild (eBay, here, etc). They are not cheap - and if bought new will come with the software. The box will also program the Smartarrow Messenger.


You only need the box if your using the MCP01, 02 or NFPA. The MPC03 does not require the box.
 

chuckie321

Member
Anybody have a lead on where I can hear the different tones on these? I'm curious what the composite tones sound like.
 
OP
OP
PJH

PJH

Member
The standard tones are the usual Whelen 295 series tones that you hear everywhere. The CP tones are more of a...mechical? sound to them. Prob youtube would be your best bet. The CP Hi-Lo sounds closer to a euroupean hi/low, the CP wall and yelp have more of a bass sound to it.


There are also some k9 alarm chirps, Tritone (like the 227 series), pulsed airhorn (short followed by long), pulsed piercer, and a couple of other misc ones.


The SC Programmer software has siren samples built into the software, but are not seperate wav's.
 

bobbyj

Premium Member
Does anybody have a wiring diagram for the BLTAREM6? I got a module off eBay recently, but it didn't come with the "lighthead" side of the connector. I can make the connections myself, but I'm not sure what wire corresponds to which side of which lighthead. Anybody know?


Thanks,


Brandt
 
OP
OP
PJH

PJH

Member
Looks like you will have to email Whelen for the PDF. Looks like they revamped their install guide section and I don't see any of the serial stuff on there at the moment. When I get in I can check my network drive.
 

bobbyj

Premium Member
PJH said:
Looks like you will have to email Whelen for the PDF. Looks like they revamped their install guide section and I don't see any of the serial stuff on there at the moment. When I get in I can check my network drive.
I actually ended up doing just that. Thanks!


Anybody know where I can get a set of legends for the MPC01? Whelen gave me the part number, but I was hoping somebody could give me a good source. Thanks!
 
OP
OP
PJH

PJH

Member
Unless you have a local installer who worked on these, you'll have to find a reseller to order it. The mpc stuff is in short supply FYI.
 

lightguy256

Junior Member
left to right----Brown, Red, Orange, Yellow, Green, Blue, Violet, Gray. If you are running LED's, unlike a standard Whelen TA controller these wires are positive not ground. The White wires are grounds.
 

ryanm

Senior Member
bobbyj said:
I actually ended up doing just that. Thanks!

Anybody know where I can get a set of legends for the MPC01? Whelen gave me the part number, but I was hoping somebody could give me a good source. Thanks!
Check with a dealer like Priority One Emergency. They've gotten me SC parts before.
 

Mrlunchbox

Premium Member
Hey buddy, let me check... I think I have either one or two brand new sheets or some few used ones which of course is better than nothing. LoL
 

fireman846

Member
ok i am in need of some of the connectors for the mpc heads i have missplaced the ones i had when i moved and my local electronic supply store looked at me funny so i turn to you guys for help!!
 

bobbyj

Premium Member
fireman846 said:
ok i am in need of some of the connectors for the mpc heads i have missplaced the ones i had when i moved and my local electronic supply store looked at me funny so i turn to you guys for help!!
which ones do you need? Might have a couple extra.


Shoot me a PM.


-Brandt
 

reynolwi

Newbie
I will be posting in the For Sale and Wanted as well but I either needing to get rid of my entire B-Link setup or im looking for a few extra components. If anyone has anything for B-Link or looking for stuff let me know
 

shues

Lifetime VIP Supporter
I just spent five minutes trying to find this thread. It's way too informative to be a normal thread. Thread stuck.
 

RamCumminsFF

Junior Member
A while back I got a used edge 9000 blink bar with an mpc01 controller, now Im getting ready to mount it and was wondering since I want to play with and try some different settings, am I better off finding (haha) a transporter setup, or just buying a mpc03 controller? Im also looking for a pair or red endcaps with alleylight cut out and mounting brackets for a 03 dodge ram 2500.
 

fireman846

Member
it would be easier to have some one program it for you then trying to find a transporter to buy took my 3 yrs to find one complete. i finally get one and my lap top craps out. so i do it all on a desk top now.
 
OP
OP
PJH

PJH

Member
Well to be technical, there is no Edge 9000 in a BLINK format. Its either a BL10000 or Edge Ultra SC for the strobe bars. They did make a "diagnostic" bar in the 9000 frame that uses serial control, but in no way can it be controlled by a MPC series controller. It uses the PCDS9 controller with custom firmware.


Used transporters are very rare to find, and new ones are $200+ last I checked. MPC03's are rare to find used and expensive to buy, but are usb programable.


A few members here can program MPC 01/02/NFPAs as we have the transporters.
 

fireman846

Member
yea sorry i didnt even see that they said edge 9000 pjh is correct it took me forever and a day and stumbled on my transporter then i got a mpc03 that had issues. good luck
 

adamogden

Member
Hello all!


I have a B-Link Edge 10000 bar that I have had up and running now for a while, with no issues. However recently while the light was on, one of the internal 15A fuses blew that controls three of the strobes on the back (positions 2, 5, and 7 strobes, all part of the built in TA). I opened it up and replaced the fuse, and as soon as it came back on, the fuse blew again. You know that classic sound that strobes make as they flash? When the fuse blows, you here that sound louder than usual just one time (and it seems to resonate from the inside of the bar, rather than the lamps), then that circuit dies. I don't want to keep replacing fuses, just to have them blow again immediately. The bar has sat on a shelf, and hasnt been moved since I got it working, so I am not sure why suddenly it is deciding to act up. Every other circuit/lamp seems to be working flawlessly.


Thoughts? Ideas? Thanks guys!
 

JohnMarcson

Site Founder
Administrator
adamogden said:
Hello all!

I have a B-Link Edge 10000 bar that I have had up and running now for a while, with no issues. However recently while the light was on, one of the internal 15A fuses blew that controls three of the strobes on the back (positions 2, 5, and 7 strobes, all part of the built in TA). I opened it up and replaced the fuse, and as soon as it came back on, the fuse blew again. You know that classic sound that strobes make as they flash? When the fuse blows, you here that sound louder than usual just one time (and it seems to resonate from the inside of the bar, rather than the lamps), then that circuit dies. I don't want to keep replacing fuses, just to have them blow again immediately. The bar has sat on a shelf, and hasnt been moved since I got it working, so I am not sure why suddenly it is deciding to act up. Every other circuit/lamp seems to be working flawlessly.


Thoughts? Ideas? Thanks guys!
Sounds like something is shorted to ground...
 
OP
OP
PJH

PJH

Member
Failing power supply's with bad cap's are known to do this. I have a 10000 that is doing the same thing... draws a bunch of amps and then blows the fuse.
 

adamogden

Member
PJH said:
Failing power supply's with bad cap's are known to do this. I have a 10000 that is doing the same thing... draws a bunch of amps and then blows the fuse.
sounds expensive.....
 

adamogden

Member
Well, I did a bit of testing. I changed the power feed to another PSU, and that PSU worked fine. I moved another PSU to the original power line, and that PSU worked fine too. When applied a new power line to the original PSU, that same PSU popped the fuse on the new power line. I also switched the wiring harness from the PSU to the lightheads themselves, just to make sure there wasn't a grounding issue between the PSU and the lamps. Both sets of lamps worked fine on the woking PSU.


Bottom line.... I need a new PSU. I can't find a single burn spot, or anything to indicate that the PSU is bad.... but that's the only component that continues to fail.


SO.... does anybody have a used PSU that want to sell me? Mine is:


Whelen Internal Sub-Assembly


P/N: 01-0267675-00


Thanks!


photo (2).jpgphoto (2).jpg
 
Last edited by a moderator:

RyanZ71

Senior Member
Folks, I am curious as to how the B-Link has held up over the years. Before I left my Sheriff's Office fleet services job back in 96, My department had started installing the B-Link systems in it's 95 and 96 model vehicles and I remember how much the officers loved the things compared to the older 80s gen Edge bars. How long did Whelen produce them and what is the overall reliability of them?
 
OP
OP
PJH

PJH

Member
The last major department that I aware of that went BLiNK is NYSP as of 4? Years ago. They switched over te entire fleet with freedoms for the tahoes/large profile vehicles and liberty for the cvpi. Both feature a custom flash pattern and a custom rear deck arrow (TA836NYSP).


Slick tops also run MPC03 controllers.


For whatever reason they programmed up arrow patterns for the bars but the t/a use a standard tactrol controller.


Made perfect sense for a fleet install as everything is "hot swappable" but the troop hq installers initially hated it as they could no longer "customize" certain installs or requests.


Unless something changed I believe NJSP also still runs blink setups with their liberty's.
 
OP
OP
PJH

PJH

Member
Mrlunchbox said:
Don't mean to switch gears... But I do still program the MPC units.
As do I, but this isn't the for sale thread ;)
 

Bwgray5592

Junior Member
I'm trying to program my blink freedom and I'm having communication issues, I have the old transporter (rs24c) setup but I'm using the newer software (5.3.3) that I had someone mail me. I do have a floppy disc that's supposed to have software on it but I don't have a computer that takes a floppy, or know anyone that does, I'm guessing it has the older software on it though. But is that my problem or could it be something eles.. Please help me lol
 

Bwgray5592

Junior Member
I was wondering does anyone know if the modules on a freedom blink are ballast or not or something special .. I have 2 blue corner modules out and I would like to replace them also would like to switch the halogen td and ally's to super LEDs
 

Online statistics

Members online
8
Guests online
229
Total visitors
237

Forum statistics

Threads
47,880
Messages
420,237
Unanswered questions
8
Members
17,267
Latest member
Kingmb98
Top Bottom